RoundCube won’t install on new server

RoundCube won’t install on new server

I can’t get RoundCube to install on a new server installation. This is not good, since the entire purpose of this server install is to test using RoundCube to manage the Dovecot Sieve.

Here’s the problem:

Code:

# ./build roundcube
mail-header-patch=yes is set in the options.conf, but is not required with this php version.
To enable the X-Mail header, set mail.add_x_header to 1 in your php.ini
cp: `/var/www/html/roundcube/logs' and `/var/www/html/roundcubemail-0.7.2/logs' are the same file
cp: `/var/www/html/roundcube/temp' and `/var/www/html/roundcubemail-0.7.2/temp' are the same file
Editing roundcube configuration...
Roundcube 0.7.2 has been installed successfully.
WARNING: Database schema needs to be updated!
Missing table 'session'
Missing table 'users'
Missing table 'cache'
Missing table 'cache_index'
Missing table 'cache_thread'
Missing table 'cache_messages'
Missing table 'contacts'
Missing table 'contactgroups'
Missing table 'contactgroupmembers'
Missing table 'identities'
Missing table 'dictionary'
Missing table 'searches'

Do you want to run the update queries to get the schmea fixed? (y/N)
y
MDB2 Error: no such table (-18): _doQuery: [Error message: Could not execute statement]
[Last executed query: TRUNCATE TABLE `messages`;
]
[Native code: 1146]
[Native message: Table 'da_roundcube.messages' doesn't exist]

This instance of Roundcube is up-to-date.
Have fun!


New install. No database existed before running the build. Can’t have fun; it didn’t work :(.

CentOS 6.2

PHP version 5.3.14, running as CLI for now (will convert to mod_ruid2 if I can get this to work).

MySQL version 5.5.25a

Zend Guard is installed but not working (still can’t figure out why) but I don’t see that as a reason why CustomBuild can’t build RoundCube.

Using the my-large.cnf file.

Any ideas?

Jeff

Comments are closed.