Custombuild Apache+Php-fpm

Custombuild Apache+Php-fpm

Hi,

I have upgraded to Apache+Php-fpm56
Everything seams to be ok on the normal websites but on the https websites after a day they dont work anymore i have to do service httpd restart and everithing starts working for another day.

All websites are wordpress, there are 4 sites on a vps 4 cores / 8.192 MB / CentOS 7

Also i noticed that after a time if i do httpd status i get the following:
[root@nl custombuild]# service httpd status
Redirecting to /bin/systemctl status httpd.service
httpd.service – The Apache HTTP Server
Loaded: loaded (/etc/systemd/system/httpd.service; enabled)
Active: active (running) since Thu 2017-02-16 11:43:03 CET; 19min ago
Process: 30076 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=1/FAILURE)
Process: 30069 ExecReload=/usr/sbin/httpd $OPTIONS -k graceful (code=exited, status=0/SUCCESS)
Main PID: 30088 (httpd)
Status: "Total requests: 274; Idle/Busy workers 100/0;Requests/sec: 0.239; Bytes served/sec: 13KB/sec"
CGroup: /system.slice/httpd.service
├─ 915 /usr/sbin/httpd -DFOREGROUND
├─ 3069 /usr/sbin/httpd -DFOREGROUND
├─ 8641 /usr/sbin/httpd -DFOREGROUND
├─ 8690 /usr/sbin/httpd -DFOREGROUND
├─ 8730 /usr/sbin/httpd -DFOREGROUND
├─ 8737 /usr/sbin/httpd -DFOREGROUND
├─ 8738 /usr/sbin/httpd -DFOREGROUND
├─30088 /usr/sbin/httpd -DFOREGROUND
├─30097 /usr/sbin/httpd -DFOREGROUND
├─30106 /usr/sbin/httpd -DFOREGROUND
└─30108 /usr/sbin/httpd -DFOREGROUND

But the strange thing is that everithing is working….
also php-fpm56.log
[16-Feb-2017 11:43:03] NOTICE: reloading: execvp("/usr/local/php56/sbin/php-fpm56", {"/usr/local/php56/sbin/php-fpm56", "–nodaemonize"})
[16-Feb-2017 11:43:03] NOTICE: using inherited socket fd=7, "/usr/local/php56/sockets/webapps.sock"
[16-Feb-2017 11:43:03] NOTICE: using inherited socket fd=7, "/usr/local/php56/sockets/webapps.sock"
[16-Feb-2017 11:43:03] NOTICE: using inherited socket fd=8, "/usr/local/php56/sockets/admin.sock"
[16-Feb-2017 11:43:03] NOTICE: using inherited socket fd=8, "/usr/local/php56/sockets/admin.sock"
[16-Feb-2017 11:43:03] NOTICE: using inherited socket fd=9, "/usr/local/php56/sockets/bsoft.sock"
[16-Feb-2017 11:43:03] NOTICE: using inherited socket fd=9, "/usr/local/php56/sockets/bsoft.sock"
[16-Feb-2017 11:43:03] NOTICE: using inherited socket fd=10, "/usr/local/php56/sockets/delbianco.sock"
[16-Feb-2017 11:43:03] NOTICE: using inherited socket fd=10, "/usr/local/php56/sockets/delbianco.sock"
[16-Feb-2017 11:43:03] NOTICE: using inherited socket fd=11, "/usr/local/php56/sockets/tech.sock"
[16-Feb-2017 11:43:03] NOTICE: using inherited socket fd=11, "/usr/local/php56/sockets/tech.sock"
[16-Feb-2017 11:43:03] NOTICE: fpm is running, pid 24864
[16-Feb-2017 11:43:03] NOTICE: ready to handle connections
[16-Feb-2017 11:43:03] NOTICE: systemd monitor interval set to 10000ms

Nothing strange


Comments are closed.